View Issue Details

IDProjectCategoryView StatusLast Update
0002027DraftBugpublic2015-12-15 13:15
ReporterpaulkAssigned Toyorik 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformOSWindowsOS Version7 (64-bit)
Product Version0.14 
Target VersionFixed in Version0.16 
Summary0002027: Draft.offset with bind=True is broken
DescriptionProblems calling Draft.offset with bind=True
1. creates a Face object, not a document object
2. does not replace the passed-in document object, even when copymode is false
Steps To Reproduceimport Draft
x = Draft.makeLine(FreeCAD.Vector(0,0,0),FreeCAD.Vector(30,0,0))
print x
# prints "<Part::Part2DObject>" to console

y = Draft.offset(x,FreeCAD.Vector(0,5,0),bind=True)
# nothing added or changed in document tree
print y
# prints "<Face object at ...>" to console
Additional InformationOS: Windows 7
Word size: 64-bit
Version: 0.14.3700 (Git)
Branch: releases/FreeCAD-0-14
Hash: 32f5aae0a64333ec8d5d160dbc46e690510c8fe1
Python version: 2.7.6
Qt version: 4.8.5
Coin version: 4.0.0a
SoQt version: 1.6.0a
OCC version: 6.6.0
TagsNo tags attached.

Activities

yorik

2015-03-28 01:57

administrator   ~0005950

It is not broken, it is by design (so the result of the offset can be used in several different tools). But indeed it should be moved out of Draft so it doesn't confuse the user.

Issue History

Date Modified Username Field Change
2015-03-27 02:34 paulk New Issue
2015-03-28 01:57 yorik Note Added: 0005950
2015-03-28 01:57 yorik Assigned To => yorik
2015-03-28 01:57 yorik Status new => assigned
2015-12-03 20:26 yorik Changeset attached => FreeCAD Master master cf1c0227
2015-12-03 20:26 yorik Status assigned => closed
2015-12-03 20:26 yorik Resolution open => fixed
2015-12-15 13:15 yorik Fixed in Version => 0.16