View Issue Details

IDProjectCategoryView StatusLast Update
0001854FreeCADBugpublic2015-12-18 22:42
ReporterjmaustpcAssigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformWindows and LinuxOSKubuntu OS Version14.04
Product Version0.15 
Target VersionFixed in Version0.16 
Summary0001854: Draft Clone of Sketch, selection of sketch mistakenly produces a Pad on the Draft Clone
DescriptionIf a Draft Clone is made of a Sketch, and the Sketch is then selected, when a PartDesign Pad is applied the Pad is created on the Draft Clone rather than the Sketch.
Steps To ReproduceCreate a Sketch
Create a Draft Clone of that Sketch
Select Sketch in treeview
In PartDesign WB click Pad
Pad is produced from the Clone even though Sketch had been selected

Also, if Sketch is selected again and a second Pad is attempted, an error message pops up...."Please create a sketch or 2D object first"

Additional InformationThe file attached contains a simple Sketch and a Draft Clone of it. If you go to the PartDesign workbench, select Sketch and apply a Pad, the Pad will appear on the Draft Clone.
TagsNo tags attached.

Activities

jmaustpc

2014-12-09 15:16

manager  

sketchclonewrongselectionbugexample.fcstd (Attachment missing)

yorik

2014-12-09 19:43

administrator   ~0005364

Hmm the problem is that inside the Pad command, there is a "validateSketch" function that runs, and declares the sketch ineligible when it is already used by another feature, which is the case when you make a clone of it.

Modifying that function to except the case when it is a Draft clone is IMHO a bad idea, because it would make the PartDesign module depend on the Draft module. And modify the Draft clone to loose its relationship with the sketch is of course contrary to the very idea.

So actually I have no clear idea of how to solve this, except from outputting a warning message that would help the user to identify the cause of the problem...

DeepSOIC

2014-12-13 19:20

developer   ~0005380

I have a clear idea that it should be simply allowed to pad (and otherwise reference) a sketch multiple times. It is so with most (all?) other objects. Outputting a warning like "referencing a sketch more than once" sounds good to me.

yorik

2014-12-29 20:46

administrator   ~0005469

I'm not sure about this, I'd prefer to leave this decision to someone who is more responsible than me for the PartDesign WB...

wmayer

2015-01-24 12:27

administrator   ~0005701

IMO we shouldn't undermine the linear workflow in Part design because otherwise we may get a big mess when allowing to use a sketch for more than one operation.

Since the Clone function doesn't link the sketch for modelling purposes we could implement a special property link type (a new class or a special mode in PropertyLink) that technically links an object (in order to keep the recompute working) but semantically doesn't do so.

So, the validateSketch then could search for objects linking by purpose and filter out objects like the Clone feature.

DeepSOIC

2015-12-18 22:16

developer   ~0006615

BTW, the issue was fixed! please close.

yorik

2015-12-18 22:42

administrator   ~0006616

>>> OBEYING THE ORDER

Issue History

Date Modified Username Field Change
2014-12-09 15:16 jmaustpc New Issue
2014-12-09 15:16 jmaustpc Status new => assigned
2014-12-09 15:16 jmaustpc Assigned To => yorik
2014-12-09 15:16 jmaustpc File Added: sketchclonewrongselectionbugexample.fcstd
2014-12-09 19:43 yorik Note Added: 0005364
2014-12-13 19:20 DeepSOIC Note Added: 0005380
2014-12-29 20:46 yorik Note Added: 0005469
2014-12-29 20:47 yorik Status assigned => new
2014-12-29 20:50 yorik Assigned To yorik =>
2015-01-20 23:38 yorik Target Version 0.15 =>
2015-01-24 12:27 wmayer Note Added: 0005701
2015-12-18 22:16 DeepSOIC Note Added: 0006615
2015-12-18 22:42 yorik Note Added: 0006616
2015-12-18 22:42 yorik Status new => closed
2015-12-18 22:42 yorik Resolution open => fixed
2015-12-18 22:42 yorik Fixed in Version => 0.16