View Issue Details

IDProjectCategoryView StatusLast Update
0001821FreeCADBugpublic2015-01-24 15:37
ReporterlanciauxAssigned Toyorik 
PrioritynormalSeverityblockReproducibilityalways
Status closedResolutionfixed 
Product Version0.14 
Target VersionFixed in Version0.15 
Summary0001821: ASCII - ARCH SURVEY - Modification 5912342e failed on 32 bits SUSE 12.3 or 13.1
DescriptionI have all latest python & Pivy libs installed when required to compile FreeCad as I follow its modifications for several months now

Since this modification of FreeCad Master, I've had the program to stop immediately at main launch on 32 bits Suse 12.3 or 13.1 with similar text 'ascii' codec can't decode byte 0xc2 in position xyz ordinal not in range(128)' . But it works on Opensuse 13.1 64 bits except for this point in Arch command Survey.

Traceback (most recent call last):
  File "/usr/local/Mod/Arch/ArchCommands.py", line 650, in addSelection
    self.callback(True)
  File "/usr/local/Mod/Arch/ArchCommands.py", line 748, in survey
    t = t.replace("^2","²")
<type 'exceptions.UnicodeDecodeError'>: 'ascii' codec can't decode byte 0xc2 in position 0: ordinal not in range(128)
TagsNo tags attached.

Relationships

has duplicate 0001825 closedyorik DRAFT - COTATION command - No way to have dimension of a radius, a circle or curved vertex 
has duplicate 0001824 closedyorik ARCH Survey - ASCII Unicode encode attibute missing for vertex 

Activities

yorik

2014-11-09 19:27

administrator   ~0005298

That changeset is not related to the problem, but I already found the cause here...

shoogen

2014-11-10 13:16

developer   ~0005299

Last edited: 2014-11-10 13:25

View 2 revisions

I don't like this fix. I refuse to call it 'solution'
I think this will fall apart, sooner or later. At least with python3
IMHO: the anno.LabelText should be a unicode object.
So I would suggest to use the replace function on a unicode object with two unicode parameters.
t.replace(u"^2",u"\N{SUPERSCRIPT TWO}")

lanciaux

2014-11-10 17:18

reporter   ~0005300

Erm Erm ... i didn't want to hurt anyone when I met this trouble. Here is my point with no technical idea :

1. Arch Survey command is well fixed with timestamp '039cacbf' ;

2. Main FreeCAD is not anymore runnable in OpenSuse 12.3 or 13.1 32 bits due to apparently some Python related trouble with Unicode and they have well emerged with '5912342e' modification ;

3. Because having poor knowledge in Python and unable to give - as now - appropriate code to fix, I've installed OpenSuse 13.2 64 bits on VirtualBox system which was failing since '5912342e' ... and FreeCAD works directly.

Thus this is really in Python problem reside and Shoogen could be right - for what i have read about Python3 unicode just now, acceptable problem of Python2 could emerge faster with Python3.

yorik

2015-01-19 17:17

administrator   ~0005676

shoogen for me this is fixed. Do you want to work any more on it?

yorik

2015-01-24 15:37

administrator   ~0005711

Let's considered fixed for now, okay? Reopen if needed...

Issue History

Date Modified Username Field Change
2014-11-09 16:50 lanciaux New Issue
2014-11-09 19:17 yorik Changeset attached => FreeCAD Master master 5912342e
2014-11-09 19:27 yorik Note Added: 0005298
2014-11-09 19:27 yorik Assigned To => yorik
2014-11-09 19:27 yorik Status new => assigned
2014-11-09 19:41 yorik Changeset attached => FreeCAD Master master 039cacbf
2014-11-09 19:41 yorik Status assigned => closed
2014-11-09 19:41 yorik Resolution open => fixed
2014-11-10 13:16 shoogen Note Added: 0005299
2014-11-10 13:16 shoogen Status closed => feedback
2014-11-10 13:16 shoogen Resolution fixed => reopened
2014-11-10 13:25 shoogen Note Edited: 0005299 View Revisions
2014-11-10 17:18 lanciaux Note Added: 0005300
2014-11-10 17:18 lanciaux Status feedback => assigned
2014-11-11 18:37 yorik Relationship added parent of 0001825
2014-11-11 18:37 yorik Relationship deleted parent of 0001825
2014-11-11 18:37 yorik Relationship added has duplicate 0001825
2014-11-11 19:03 yorik Relationship added has duplicate 0001824
2015-01-19 17:17 yorik Note Added: 0005676
2015-01-19 17:18 yorik Status assigned => feedback
2015-01-24 15:37 yorik Note Added: 0005711
2015-01-24 15:37 yorik Status feedback => closed
2015-01-24 15:37 yorik Resolution reopened => fixed
2015-01-24 15:37 yorik Fixed in Version => 0.15