View Issue Details

IDProjectCategoryView StatusLast Update
0001767FreeCADBugpublic2015-01-19 17:32
Reportermore11Assigned Toyorik 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformDell XPSOSWindows 7 OS Version64 bit
Product Version0.14 
Target VersionFixed in Version0.15 
Summary0001767: Added an angular dimension and it doesn't work
DescriptionTraceback (most recent call last):
  File "C:\Program Files (x86)\FreeCAD 0.14\Mod\Draft\Draft.py", line 3470, in attach
    self.updateData(vobj.Object,None)
  File "C:\Program Files (x86)\FreeCAD 0.14\Mod\Draft\Draft.py", line 3506, in updateData
    self.string = DraftGui.displayExternal(a,obj.ViewObject.Decimals,'Angle',su).decode("latin1").encode("utf8")
<type 'exceptions.UnicodeEncodeError'>: 'ascii' codec can't encode character u'\xb0' in position 6: ordinal not in range(128)

Traceback (most recent call last):
  File "C:\Program Files (x86)\FreeCAD 0.14\Mod\Draft\Draft.py", line 3659, in onChanged
    self.updateData(vobj.Object, None)
  File "C:\Program Files (x86)\FreeCAD 0.14\Mod\Draft\Draft.py", line 3506, in updateData
    self.string = DraftGui.displayExternal(a,obj.ViewObject.Decimals,'Angle',su).decode("latin1").encode("utf8")
<type 'exceptions.UnicodeEncodeError'>: 'ascii' codec can't encode character u'\xb0' in position 6: ordinal not in range(128)

Steps To ReproduceLoad my drawing file. https://dl.dropboxusercontent.com/u/106944188/FreeCAD/ordinal%20not%20in%20range/midbashorn.FCStd
Additional InformationOS: Windows 7
Word size: 32-bit
Version: 0.14.3700 (Git)
Branch: releases/FreeCAD-0-14
Hash: 32f5aae0a64333ec8d5d160dbc46e690510c8fe1
Python version: 2.6.2
Qt version: 4.5.2
Coin version: 3.1.0
SoQt version: 1.4.1
OCC version: 6.5.1
TagsNo tags attached.

Activities

more11

2014-09-29 17:10

reporter   ~0005166

Known bug: http://forum.freecadweb.org/viewtopic.php?f=3&t=7383&start=10

yorik

2014-09-29 19:44

administrator   ~0005167

Last edited: 2014-09-29 19:44

View 2 revisions

This is a known problem with coin3. I didn't find a solution that works for everybody yet

yorik

2015-01-19 17:32

administrator   ~0005678

This is now fixed since quite some time in 0.15

Issue History

Date Modified Username Field Change
2014-09-29 16:55 more11 New Issue
2014-09-29 17:10 more11 Note Added: 0005166
2014-09-29 19:43 yorik Description Updated View Revisions
2014-09-29 19:44 yorik Note Added: 0005167
2014-09-29 19:44 yorik Note Edited: 0005167 View Revisions
2014-09-29 19:44 yorik Assigned To => yorik
2014-09-29 19:44 yorik Status new => assigned
2015-01-19 17:32 yorik Note Added: 0005678
2015-01-19 17:32 yorik Status assigned => closed
2015-01-19 17:32 yorik Resolution open => fixed
2015-01-19 17:32 yorik Fixed in Version => 0.15