View Issue Details

IDProjectCategoryView StatusLast Update
0001763FreeCADFeaturepublic2014-10-23 10:56
ReportershoogenAssigned Toshoogen 
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.15 
Summary0001763: use UTF8 for filenames
Descriptionhttp://tracker.dev.opencascade.org/view.php?id=22484
http://git.dev.opencascade.org/gitweb/?p=occt.git;a=shortlog;h=refs/heads/CR22484
TagsNo tags attached.

Relationships

parent of 0001795 closedyorik Arch adapt IFC exporters to accept unicode filenames 
related to 0001027 closedshoogen FreeCAD UTF-8 encoded PyString objects are used instead of unicode objects to pass unicode data to the python interpreter 
child of 0001573 closedshoogen FreeCAD migration to OCCT 6.8.0 
child of 0001411 closedshoogen FreeCAD Importing and Exporting fails on Windows due to filepath encoding 
child of 0001421 closedshoogen FreeCAD STEP import failure due to non-ASCII chars path 
child of 0000812 closedshoogen FreeCAD Does not import files with the national chars in the file name. 

Activities

shoogen

2014-09-24 13:28

developer   ~0005152

if the change to python unicode objects would be rejected and support of occt 6.8.0 would be dropped at once, a simple
git revert 040c19b1c1618043631e45c74ddd30536cf09252
would implement this feature

shoogen

2014-10-13 20:59

developer   ~0005216

if OCC does not fix the problem after the beta the workaround needs to be reenabled at some places

Issue History

Date Modified Username Field Change
2014-09-24 11:39 shoogen New Issue
2014-09-24 11:39 shoogen Status new => assigned
2014-09-24 11:39 shoogen Assigned To => shoogen
2014-09-24 11:39 shoogen Relationship added child of 0001573
2014-09-24 11:41 shoogen Relationship added child of 0001411
2014-09-24 11:41 shoogen Relationship added related to 0001027
2014-09-24 11:42 shoogen Relationship added child of 0001421
2014-09-24 11:43 shoogen Relationship added child of 0000812
2014-09-24 12:38 shoogen Summary use TCollection_ExtendedString for filenames => use UTF8 for filenames
2014-09-24 13:28 shoogen Note Added: 0005152
2014-10-11 12:38 shoogen Status assigned => closed
2014-10-11 12:38 shoogen Resolution open => fixed
2014-10-11 12:38 shoogen Fixed in Version => 0.15
2014-10-13 20:59 shoogen Note Added: 0005216
2014-10-13 20:59 shoogen Status closed => feedback
2014-10-13 20:59 shoogen Resolution fixed => reopened
2014-10-13 20:59 shoogen Status feedback => assigned
2014-10-14 18:21 shoogen Status assigned => closed
2014-10-14 18:21 shoogen Resolution reopened => fixed
2014-10-22 07:31 shoogen Relationship added parent of 0001795