View Issue Details

IDProjectCategoryView StatusLast Update
0001759FreeCADBugpublic2014-12-29 00:37
ReportershoogenAssigned To 
PrioritylowSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version0.15 
Target VersionFixed in Version0.15 
Summary0001759: python interface allows to break sketches by invalid GeomIds
Descriptioncurrently neither the Constraint constructor nor the addConstraint method check, if the supplies geomIds are valid. This leads to broken sketches.

addConstraint should raise an exception, if the referenced Geometry (or Sub-Geometry) is not present in the Sketch.

Currently the sketcher does not perform any integrity checks resulting in exiting due to assertions fails and crashes due to out-of-bounds memory access.
Despite the fact that FreeCAD should not crash because of invalid sketches, those sketches should be handled gracefully.
This means marking them with a exclamation mark in tree view. And allowing to delete offending constraints in the task view.
But it should not be easy for a user to create such a sketch from the python interface.
Tagssketcher

Relationships

related to 0001720 closedwmayer Freecad crash when handling invalid sketches 

Activities

wmayer

2014-12-29 00:37

administrator   ~0005461

Ticket 1720 is fixed

Issue History

Date Modified Username Field Change
2014-09-20 10:01 shoogen New Issue
2014-09-20 10:02 shoogen Relationship added related to 0001720
2014-09-20 10:02 shoogen Tag Attached: sketcher
2014-12-29 00:37 wmayer Note Added: 0005461
2014-12-29 00:37 wmayer Status new => closed
2014-12-29 00:37 wmayer Resolution open => fixed
2014-12-29 00:37 wmayer Fixed in Version => 0.15