View Issue Details

IDProjectCategoryView StatusLast Update
0001748FreeCADBugpublic2014-12-09 10:51
ReportermtrobackAssigned Towmayer 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
PlatformPCOSWindowsOS Version7
Product Version0.14 
Target VersionFixed in Version0.15 
Summary0001748: FreeCAD crashes when importing step file
DescriptionEvery time I try to import the attached step file FreeCAD crashes. However it works in FreeCAD 0.13
Steps To ReproduceOpen new document.
Import the file attached to this report.
Wait for the crash (it takes a while).
Additional InformationOS: Windows 7
Word size: 64-bit
Version: 0.14.3700 (Git)
Branch: releases/FreeCAD-0-14
Hash: 32f5aae0a64333ec8d5d160dbc46e690510c8fe1
Python version: 2.7.6
Qt version: 4.8.5
Coin version: 4.0.0a
SoQt version: 1.6.0a
OCC version: 6.6.0
TagsSTEP

Relationships

duplicate of 0001714 closedwmayer FreeCAD 0.14 Stable crashes when importing a step model 

Activities

mtroback

2014-09-16 05:55

reporter  

Failing_step.rar (Attachment missing)

shoogen

2014-09-16 06:36

developer   ~0005103

Last edited: 2014-09-16 06:41

View 2 revisions

I can't reproduce the problem
I can open the file from the Download manager
I can import the file form Menu -> Part -> Import CAD
I can import the file from Menu -> Import -> Step with color

Debug Build
OS: Windows 7
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.15.3993
Python version: 2.7.5
Qt version: 4.8.6
Coin version: 4.0.0a
SoQt version: 1.6.0a
OCC version: 6.7.0
merge-base: 5d406144aac72e7aca792023253054bc37d81d02

wmayer

2014-09-16 07:46

administrator   ~0005104

It's fixed in master and the 0.14 release branch.

Issue History

Date Modified Username Field Change
2014-09-16 05:55 mtroback New Issue
2014-09-16 05:55 mtroback File Added: Failing_step.rar
2014-09-16 06:36 shoogen Note Added: 0005103
2014-09-16 06:41 shoogen Note Edited: 0005103 View Revisions
2014-09-16 07:46 wmayer Relationship added duplicate of 0001714
2014-09-16 07:46 wmayer Note Added: 0005104
2014-09-16 07:46 wmayer Status new => closed
2014-09-16 07:46 wmayer Assigned To => wmayer
2014-09-16 07:46 wmayer Resolution open => fixed
2014-09-16 07:46 wmayer Fixed in Version => 0.15
2014-10-05 19:15 shoogen Tag Attached: STEP
2014-12-09 10:51 shoogen Relationship added has duplicate 0001853
2014-12-09 10:54 shoogen Relationship deleted has duplicate 0001853