View Issue Details

IDProjectCategoryView StatusLast Update
0001714FreeCADBugpublic2014-12-09 10:54
Reporteremh203Assigned Towmayer 
PriorityhighSeveritycrashReproducibilityalways
Status closedResolutionfixed 
PlatformWindows 7OSOS Version
Product Version0.14 
Target VersionFixed in Version0.15 
Summary0001714: FreeCAD 0.14 Stable crashes when importing a step model
DescriptionI have a step model for a Molex CAT 5 connector that will cause FreeCAD 0.14 to crash on import.


I used the model from here (it is also attached)

http://www.digikey.com/product-detail/en/0855085001/WM4590-ND/1851210
Steps To ReproduceStart FreeCAD. File->Import and then select 855085001.stp
TagsSTEP

Relationships

has duplicate 0001748 closedwmayer FreeCAD crashes when importing step file 
has duplicate 0001777 closed Freecad Has Stopped Working 
has duplicate 0001853 closedshoogen Crash on opening STP file 

Activities

normandc

2014-08-31 19:15

manager   ~0005039

It is not crashing for me. Actually I can open the step file just fine.

Could you please provide your FULL FreeCAD info as explained in this forum topic: http://forum.freecadweb.org/viewtopic.php?f=3&t=2264

My FreeCAD info:
OS: Ubuntu 14.04.1 LTS
Word size: 64-bit
Version: 0.14.3702 (Git)
Branch: releases/FreeCAD-0-14
Hash: b3368125c63289ec8ce9faec2b2ae4c78d436406
Python version: 2.7.6
Qt version: 4.8.6
Coin version: 4.0.0a
SoQt version: 1.6.0a
OCC version: 6.7.0

normandc

2014-08-31 19:16

manager   ~0005040

I deleted the Zip file provided since we have no way of knowing if it can be distributed freely. The direct download link from the manufacturer is here: http://www.molex.com/pdm_docs/stp/85508-5001_stp.zip

emh203

2014-08-31 23:36

reporter   ~0005041

Here it is. Also, I created a fresh VM with Windows 7 and grabbed the latest stable release with the same result.

My Main Machine:

OS: Windows 7
Word size: 64-bit
Version: 0.14.3700 (Git)
Branch: releases/FreeCAD-0-14
Hash: 32f5aae0a64333ec8d5d160dbc46e690510c8fe1
Python version: 2.7.6
Qt version: 4.8.5
Coin version: 4.0.0a
SoQt version: 1.6.0a


The Windows 7 VM:

OS: Windows 7
Word size: 64-bit
Version: 0.14.3700 (Git)
Branch: releases/FreeCAD-0-14
Hash: 32f5aae0a64333ec8d5d160dbc46e690510c8fe1
Python version: 2.7.6
Qt version: 4.8.5
Coin version: 4.0.0a
SoQt version: 1.6.0a

emh203

2014-08-31 23:38

reporter   ~0005042

Also, if it helps, I can make a video capture of the issue

normandc

2014-09-01 00:36

manager   ~0005043

FYI, you have forgotten to switch to the Part workbench before copying to the clipboard (as was explained on the link). As a result your FreeCAD info is missing the OCC version.

But I know that the 64-Bit version you are using was provided with OCC 6.6.0. I wonder if it's why you are getting a crash, and I'm not. OCC is the geometric modeling kernel and STEP import relies on it.

I don't think a video capture would provide helpful info. A crash log would but I do not know how to get one on Windows. Hopefully a "real" developer will provide more assistance.

Checking if any other STEP file crashes FreeCAD may be useful.

normandc

2014-09-01 00:42

manager   ~0005044

Last edited: 2014-09-01 00:43

View 2 revisions

Does the path to the STEP file on your PC contain non-ASCII characters? I wonder if it would be related to #0001421 (but a workaround was committed before the current stable was published).

emh203

2014-09-01 03:10

reporter   ~0005047

I just loaded the 32-bit version and it imports correctly without a crash.

The 64-Bit version still crashed even if the file has all ascii characters. Also, I tried another STEP file and it worked ok (90272A106 from McMaster Carr). There is something about that STEP file and the 64-bit version.

emh203

2014-09-01 03:12

reporter   ~0005048

Also... You were correct on the OCC version:

OS: Windows 7
Word size: 64-bit
Version: 0.14.3700 (Git)
Branch: releases/FreeCAD-0-14
Hash: 32f5aae0a64333ec8d5d160dbc46e690510c8fe1
Python version: 2.7.6
Qt version: 4.8.5
Coin version: 4.0.0a
SoQt version: 1.6.0a
OCC version: 6.6.0

emh203

2014-09-01 03:13

reporter   ~0005049

OS: Windows 7
Here is the data on the 32-bit windows version that worked:

Word size: 32-bit
Version: 0.14.3700 (Git)
Branch: releases/FreeCAD-0-14
Hash: 32f5aae0a64333ec8d5d160dbc46e690510c8fe1
Python version: 2.6.2
Qt version: 4.5.2
Coin version: 3.1.0
SoQt version: 1.4.1
OCC version: 6.5.1

wmayer

2014-09-01 17:13

administrator   ~0005054

Happens with object labels with only digits in it

emh203

2014-09-03 12:55

reporter   ~0005060

Will this be fixed? That seems to be a limitation that is frustrating to a new user.

wmayer

2014-09-03 13:04

administrator   ~0005062

It IS fixed now. A new 0.14 version will be uploaded soon.

Issue History

Date Modified Username Field Change
2014-08-27 13:44 emh203 New Issue
2014-08-27 13:44 emh203 File Added: 855085001.stp
2014-08-31 19:15 normandc Note Added: 0005039
2014-08-31 19:15 normandc File Deleted: 855085001.stp
2014-08-31 19:16 normandc Note Added: 0005040
2014-08-31 23:36 emh203 Note Added: 0005041
2014-08-31 23:38 emh203 Note Added: 0005042
2014-09-01 00:36 normandc Note Added: 0005043
2014-09-01 00:42 normandc Note Added: 0005044
2014-09-01 00:43 normandc Note Edited: 0005044 View Revisions
2014-09-01 03:10 emh203 Note Added: 0005047
2014-09-01 03:12 emh203 Note Added: 0005048
2014-09-01 03:13 emh203 Note Added: 0005049
2014-09-01 17:13 wmayer Note Added: 0005054
2014-09-01 17:13 wmayer Assigned To => wmayer
2014-09-01 17:13 wmayer Status new => confirmed
2014-09-01 17:39 wmayer Changeset attached => FreeCAD Master master e5a54d07
2014-09-01 17:39 wmayer Status confirmed => closed
2014-09-01 17:39 wmayer Resolution open => fixed
2014-09-03 12:55 emh203 Note Added: 0005060
2014-09-03 12:55 emh203 Status closed => feedback
2014-09-03 12:55 emh203 Resolution fixed => reopened
2014-09-03 13:04 wmayer Note Added: 0005062
2014-09-03 13:04 wmayer Status feedback => closed
2014-09-03 13:04 wmayer Resolution reopened => fixed
2014-09-03 13:04 wmayer Fixed in Version => 0.15
2014-09-16 07:46 wmayer Relationship added has duplicate 0001748
2014-10-05 19:14 shoogen Tag Attached: STEP
2014-10-05 19:18 shoogen Relationship added has duplicate 0001777
2014-12-09 10:54 shoogen Relationship added has duplicate 0001853