View Issue Details

IDProjectCategoryView StatusLast Update
0001707PartDesignBugpublic2018-09-16 14:37
Reporterian.reesAssigned Towandererfan 
PrioritynormalSeverityblockReproducibilityalways
Status closedResolutionfixed 
PlatformLinux 64 bitOSFedoraOS Version20
Product Version 
Target Version0.18Fixed in Version0.17 
Summary0001707: PartDesign - Inconsistent handling of multiple pieces
DescriptionIt's possible to create parts using normal PartDesign tools, which have multiple unattached pieces (for lack of a better word), but the current iteration of PartDesign only seems capable of handling parts with single pieces. So, some pieces get thrown away, leaving only one of the pieces in the 3D view.
Steps To ReproduceOpen attached document, change the depth of the pocket from 9mm to >=10mm. Observe that one end of the box disappears.

Instead, either the two end pieces should remain (preferable in my opinion), or the user should be informed that this is an error and the change in pocket depth shouldn't be allowed.
TagsNo tags attached.

Relationships

related to 0001601 closedwandererfan Pad fails on 'non-one-solid' element 
has duplicate 0003401 closedwandererfan Sketch goes to pad and the pad vanishes without explaination, please add warning message 
related to 0002998 closedwandererfan Sketch with 2 shapes (rings) wont pad - Broken face 

Activities

ian.rees

2014-08-23 23:14

developer  

pocket bug.fcstd (8,915 bytes)

Kunda1

2017-01-31 01:19

manager   ~0008115

Forum thread: https://forum.freecadweb.org/viewtopic.php?f=10&t=20386

Kunda1

2017-01-31 18:20

manager   ~0008132

per wandererfan in https://forum.freecadweb.org/viewtopic.php?p=157290#p157290
> The Part Design Workbench provides tools for modelling complex solid parts and is based on a Feature editing methodology to produce a single contiguous solid. It is intricately linked with the Sketcher Workbench.

> What is a single contiguous solid? This is an item like a casting or something machined from a single block of metal. If the item involves nails, screws, glue or welding, it is not a single contiguous solid. As a practical example, PartDesign would not be used to model a wooden chair, but would be used to model the subcomponents (legs, slats, seat, etc). The subcomponents are combined using the Assembly, Part or Draft workbench.

ian.rees

2017-01-31 18:39

developer   ~0008135

This item is not about whether Part Design does or does not support contiguous solids, it's about making the UI consistent.

"either the two end pieces should remain (preferable in my opinion), or the user should be informed that this is an error and the change in pocket depth shouldn't be allowed."

normandc

2017-06-18 00:17

manager   ~0009436

[quote=ian.rees]"either the two end pieces should remain (preferable in my opinion)[/quote]
It has clearly been stated by @ickby on the forum that on 0.17 and PartDesignNext, a Body cannot contain more than one solid. It's both a design decision coming from the project founder jriegel as well as something that apparently cannot be circumvented in the code.

So this becomes a usability issue - the user should be informed that an operation that creates more than a single solid isn't permitted and should be presented with a choice: cancel to edit the sketch or proceed and remove one of the solids. Showing a preview of which solid will be discarded in translucent red, like for transformation errors, would be helpful.

normandc

2017-06-18 00:18

manager   ~0009437

Setting target version as 0.17 - this has been a long standing source of confusion for users, doing something about it for 0.17 would be desirable.

Kunda1

2017-06-21 10:41

manager   ~0009477

Changing to 'blocker' since this is a departure from the current FC paradigm (per normandc's comment) and the user isn't informed.

normandc

2018-09-16 14:37

manager   ~0011758

On July 13th 2018 a warning message was added in master as well as in the releases/FreeCAD-0-17 branch. Related commits are 1889f1f8, 1dd565ee and 5c3f7bf8. This is included in FreeCAD 0.17.13528 or later.

It has been discussed on the forum that the single solid restriction may be lifted in the future, but there is no plan to implement it, nor any volunteer to assume this work, so I'm closing this report now as fixed. What we can do is create a new report as enhancement request rather than bug.

Issue History

Date Modified Username Field Change
2014-08-23 23:14 ian.rees New Issue
2014-08-23 23:14 ian.rees File Added: pocket bug.fcstd
2017-01-09 18:03 wmayer Relationship added related to 0001601
2017-01-16 10:21 Kunda1 Project FreeCAD => PartDesign
2017-01-31 01:19 Kunda1 Note Added: 0008115
2017-01-31 18:20 Kunda1 Note Added: 0008132
2017-01-31 18:20 Kunda1 Status new => feedback
2017-01-31 18:39 ian.rees Note Added: 0008135
2017-01-31 18:39 ian.rees Status feedback => new
2017-06-18 00:17 normandc Note Added: 0009436
2017-06-18 00:18 normandc Target Version => 0.17
2017-06-18 00:18 normandc Note Added: 0009437
2017-06-18 19:35 Kunda1 Status new => confirmed
2017-06-21 10:41 Kunda1 Severity minor => block
2017-06-21 10:41 Kunda1 Note Added: 0009477
2017-12-07 15:23 wmayer Target Version 0.17 => 0.18
2018-04-06 23:10 normandc Relationship added has duplicate 0003401
2018-06-10 04:30 normandc Relationship added related to 0002998
2018-09-16 14:37 normandc Assigned To => wandererfan
2018-09-16 14:37 normandc Status confirmed => closed
2018-09-16 14:37 normandc Resolution open => fixed
2018-09-16 14:37 normandc Fixed in Version => 0.17
2018-09-16 14:37 normandc Note Added: 0011758