View Issue Details

IDProjectCategoryView StatusLast Update
0001697FreeCADBugpublic2017-01-30 15:21
ReportershoogenAssigned Toyorik 
PrioritynoneSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.17 
Summary0001697: projection of edges fails
Description#0 0x00007f5c9a307fd0 in __cxa_throw ()
   from /usr/lib/x86_64-linux-gnu/libstdc++.so.6
#1 0x00007f5c2a143aeb in Standard_OutOfRange::Throw (this=0x5d68740)
    at /home/sebastian/Downloads/occt/drv/Standard/Standard_OutOfRange_0.cxx:12
#2 0x00007f5c2a148ad2 in Standard_Failure::Reraise (this=0x5d68740)
    at /home/sebastian/Downloads/occt/src/Standard/Standard_Failure.cxx:150
#3 0x00007f5c2a148a1b in Standard_Failure::Reraise (this=0x5d68740,
    AString=0x0)
    at /home/sebastian/Downloads/occt/src/Standard/Standard_Failure.cxx:134
#4 0x00007f5c2a1439fc in Standard_OutOfRange::Raise (AString=0x0)
    at /home/sebastian/Downloads/occt/drv/Standard/Standard_OutOfRange_0.cxx:12
#5 0x00007f5c24a39d9c in HLRBRep_Array1OfFData::ChangeValue (this=0x5689380,
    Index=1) at /home/sebastian/Downloads/occt/inc/TCollection_Array1.lxx:144
#6 0x00007f5c24a83028 in HLRBRep_Data::Update (this=0x5689310, P=...)
    at /home/sebastian/Downloads/occt/src/HLRBRep/HLRBRep_Data.cxx:636
#7 0x00007f5c24a991f8 in HLRBRep_InternalAlgo::Update (this=0x56d4ea0)
    at /home/sebastian/Downloads/occt/src/HLRBRep/HLRBRep_InternalAlgo.cxx:177
TagsOCC 7.1, OCC Bug, upstream

Relationships

related to 0001566 closed FreeCAD Projection of a helix perpendicular to helix-axis fails 
parent of 0001931 closedwmayer FreeCAD migration to OCCT 7.1 
has duplicate 0001727 closedyorik Drawing API function Drawing.projectToDXF 
related to 0002383 closedyorik Drawing Drawing lines missing or incorrect 
child of 0001612 closedyorik Draft Projecting arcs to SVG gives wrong results under certain angles 

Activities

yorik

2014-08-18 22:12

administrator   ~0004964

hm good catch.. .I checked too now, only objects that have faces are successfully projected. Indeed seems one more OCC6.7 bug...

shoogen

2014-08-19 06:02

developer   ~0004968

i think there is no difference in the cause, but only in the exception handlers inside freecad.
it seems in the release build the exception gets caught by https://github.com/FreeCAD/FreeCAD_sf_master/blob/e2f54c793cba5c51bd5e9554869770a6eeb0a6d3/src/Mod/Draft/importDXF.py#L1317
but in the debug build it seems that the exception is not converted to a python error, but rather passed up until Gui::Application.

shoogen

2014-08-19 13:50

developer   ~0004972

relation to OCCT deleted 6.8.0 since version 6.7 seems to be affected as well.

shoogen

2014-08-20 11:55

developer   ~0004978

Last edited: 2014-08-20 12:57

View 2 revisions

yorik: i think i solved the exception handling problem. Now i get an exception even when running a Debug build.

>>> Drawing.projectEx(Part.makeLine((0,0,0),(1,0,0)))
Traceback (most recent call last):
  File "<input>", line 1, in <module>
Part.OCCError: 19Standard_OutOfRange No OCCT Exception Message

yorik

2014-08-20 13:53

administrator   ~0004979

Hm yes I begin to think it was not a very good practice to put som any try/except in the Draft code.. Makes debugging harder.

Anyway there is clearly a bug with recent OCC versions that it doesn't want to project single edges (or AFAICS anything that is not a face) anymore.

shoogen

2014-09-03 22:36

developer   ~0005070

http://tracker.dev.opencascade.org/view.php?id=25214

ulrich1a

2014-09-28 21:21

reporter   ~0005163

Is this bug a duplicate of http://freecadweb.org/tracker/view.php?id=1566 ?

It worked in OCCT 6.3.0

shoogen

2014-09-29 10:56

developer   ~0005164

Thanks for pointing that out. I marked the tickets as related but not as duplicates. Because your original tickets describes problems with helices.

yorik

2017-01-25 23:38

administrator   ~0007993

This is fixed in OCC 7.1

Kunda1

2017-01-27 01:55

manager   ~0008008

Marked as resolved
Fixed in OCC 7.1

Issue History

Date Modified Username Field Change
2014-08-18 19:58 shoogen New Issue
2014-08-18 19:58 shoogen Relationship added child of 0001573
2014-08-18 19:59 shoogen Assigned To => shoogen
2014-08-18 19:59 shoogen Status new => assigned
2014-08-18 22:12 yorik Note Added: 0004964
2014-08-19 06:02 shoogen Note Added: 0004968
2014-08-19 06:07 shoogen Assigned To shoogen =>
2014-08-19 06:07 shoogen Status assigned => new
2014-08-19 08:24 shoogen Relationship added related to 0001422
2014-08-19 13:47 shoogen Summary projection of edges fails in occt 6.7.3dev => projection of edges fails
2014-08-19 13:48 shoogen Relationship deleted child of 0001573
2014-08-19 13:50 shoogen Note Added: 0004972
2014-08-20 11:55 shoogen Note Added: 0004978
2014-08-20 12:57 shoogen Note Edited: 0004978 View Revisions
2014-08-20 13:53 yorik Note Added: 0004979
2014-09-02 08:19 shoogen Relationship added has duplicate 0001727
2014-09-02 08:20 shoogen Tag Attached: OCC Bug
2014-09-03 22:36 shoogen Note Added: 0005070
2014-09-28 21:21 ulrich1a Note Added: 0005163
2014-09-29 10:50 shoogen Relationship added related to 0001566
2014-09-29 10:56 shoogen Note Added: 0005164
2015-01-23 10:14 shoogen Relationship added child of 0001612
2015-01-24 13:03 shoogen Relationship added parent of 0001931
2015-01-28 11:03 shoogen Relationship deleted related to 0001422
2016-08-05 13:28 wandererfan Relationship added related to 0002383
2017-01-11 18:37 Kunda1 Tag Attached: upstream
2017-01-25 23:38 yorik Note Added: 0007993
2017-01-27 01:53 Kunda1 Tag Attached: OCC 7.1
2017-01-27 01:55 Kunda1 Note Added: 0008008
2017-01-27 01:55 Kunda1 Status new => resolved
2017-01-27 01:55 Kunda1 Fixed in Version => 0.17
2017-01-27 01:55 Kunda1 Resolution open => fixed
2017-01-27 01:55 Kunda1 Assigned To => Kunda1
2017-01-27 01:55 Kunda1 Assigned To Kunda1 =>
2017-01-30 15:21 yorik Status resolved => closed
2017-01-30 15:21 yorik Assigned To => yorik