View Issue Details

IDProjectCategoryView StatusLast Update
0001627FreeCADBugpublic2014-08-24 09:10
ReporterobbeAssigned ToJriegel 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Platform2.26 GHz Intel Core 2 DuoOSMacintoshOS Version10.9.3
Product Version0.14 
Target VersionFixed in Version0.15 
Summary0001627: Dash instead of minus in dialogs/fields
DescriptionWhenever you wish to enter a minus, it does not use minus but a dash. This has the implication that you can not type negative values naturally on a keyboard, but must copy and paste the "minus sign" from a field where it is present.
Steps To ReproduceFor example

1. Create a new sketch.
2. Add a line.
3. Add a horizontal vertical distance constraint to the line and make sure its positive.
4. Try setting it to a negative value.
TagsNo tags attached.

Activities

wmayer

2014-07-30 12:13

administrator   ~0004881

Might be related to this issue: http://forum.freecadweb.org/viewtopic.php?f=10&t=7182

obbe

2014-07-30 12:24

reporter   ~0004882

Seems to be the same. I was also using the Swedish locale.

wmayer

2014-07-30 18:19

administrator   ~0004894

J├╝rgen, please add the alternative minus (\xe2\x88\x92) to the parser.

Jriegel

2014-08-03 17:06

administrator   ~0004910

fixed with 1da55436578fcf620802ba4e38a0c940723e07e4

needs (swedish) testing....

Issue History

Date Modified Username Field Change
2014-07-22 15:44 obbe New Issue
2014-07-30 12:13 wmayer Note Added: 0004881
2014-07-30 12:24 obbe Note Added: 0004882
2014-07-30 18:18 wmayer Assigned To => Jriegel
2014-07-30 18:18 wmayer Status new => assigned
2014-07-30 18:19 wmayer Note Added: 0004894
2014-08-03 17:06 Jriegel Note Added: 0004910
2014-08-24 09:10 wmayer Changeset attached => FreeCAD Master master 1b4190b0
2014-08-24 09:10 wmayer Status assigned => closed
2014-08-24 09:10 wmayer Resolution open => fixed
2014-08-24 09:10 wmayer Fixed in Version => 0.15