View Issue Details

IDProjectCategoryView StatusLast Update
0001588FreeCADFeaturepublic2016-10-16 16:04
ReporterbgoodrAssigned Towmayer 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformLinuxOSDebianOS Version7.4 (wheezy)
Product Version 
Target VersionFixed in Version0.17 
Summary0001588: File browser dialogs initial starting directory ignores current working directory
DescriptionThe file browser dialogs are the dialog boxes that show up for these operations:

 - Save
 - Save As
 - Open

When those dialog boxes are displayed, there is a starting directory that the file browser dialog shows to allow the user to browse within. This ticket is about how that startup directory should change and when.

At invoke, the starting directory needs to be the processes current working directory, not the users HOME directory, and should be initially be completely unrelated to any previously saved file in some other directory (e.g., not related to the files in the Recent Files List). In this case, the UNIX user cd's into a directory for a reason: That reason is that the application that is then run should be viewing files relative to that directory.

Later on, if the user does the following operations, that new directory should be the directory used in subsequent file browser dialogs:

 - Uses File/Save As... to save the drawing into a different directory, or,
 - Uses File/Open and navigates to a different directory and opens a drawing there, or,
 - Selects an existing file from the Recent Files List.

This almost seems like an enhancement request. But it is not: Ignoring the users current working directory at startup reduces useability of the tool on a operating system where that current working directory is used to manage different projects in different directories simply by cd'ing into the different project directory and reinvoking the tool. Insisting the user manage things from the Recent Files list alone is not scalable.
Steps To ReproduceFrom the Linux shell prompt, cd into some directory other than the users HOME directory. e.g.,:

  cd /tmp

Invoke FreeCAD without any options.

Click on "Create a new Empty document".

Select the Part workbench.

At this point my filename is "Unamed : 1". I have not added any objects.

First thing I want to do is save that file. I clicked File menu then Save.

The dialog box I see displayed is not in the directory I was in when I invoked the executable, but in my home directory.
Additional Informationhttp://forum.freecadweb.org/viewtopic.php?f=3&t=6825&p=55121#p55121

Build info:

    OS: Debian GNU/Linux 7.4 (wheezy)
    Word size: 64-bit
    Version: 0.14.3677 (Git)
    Branch: master
    Hash: 07c64e206d05ae662ba40ae125ba991cced7cc9e
    Python version: 2.7.3
    Qt version: 4.8.2
    Coin version: 3.1.3
    SoQt version: 1.5.0
    OCC version: 6.5.2
TagsNo tags attached.

Activities

yorik

2014-06-21 14:19

administrator   ~0004760

This is a good idea for me, but not a bug. On windows, the "normal" behaviour is to start in the user's document folder. On unixes, though, the normal is indeed to start in the current directory. So I changed this from "bug" to "feature request".

Issue History

Date Modified Username Field Change
2014-06-21 13:39 bgoodr New Issue
2014-06-21 14:18 yorik Category Bug => Feature
2014-06-21 14:19 yorik Note Added: 0004760
2016-10-16 15:35 wmayer Changeset attached => FreeCAD Master master b322668d
2016-10-16 16:04 wmayer Changeset attached => FreeCAD Master master 13298573
2016-10-16 16:04 wmayer Status new => closed
2016-10-16 16:04 wmayer Assigned To => wmayer
2016-10-16 16:04 wmayer Resolution open => fixed
2016-10-16 16:04 wmayer Fixed in Version => 0.17