View Issue Details

IDProjectCategoryView StatusLast Update
0001483FreeCADBugpublic2014-12-29 15:48
Reporterquick61Assigned Towmayer 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Versiontrunk 
Target VersionFixed in Version0.15 
Summary0001483: Bad Behavior in Part Design After Bug Fix.
DescriptionAfter implementing fix for bug 1480, another bug was exposed. Forum reference begins in this post - http://forum.freecadweb.org/viewtopic.php?f=3&t=6103&start=10#p48676

Following the "Steps To Reproduce" below, the delete action now deletes the Pad instead of the line. A second action is required to delete the line along with an action to manually refresh the screen and complete the task.

Steps To ReproduceOpen a new sketch, draw a square, close sketch and pad it.

Decide to edit sketch so open it again.

Sketch is obscured by the pad so go to Model view, select the pad and hit space to hide it.

Back to Tasks view, select a line and hit delete.

/problem 1
Pad is deleted, and line remains unaffected
/end problem 1

Select the line again and hit delete.

/problem 2
Line width changes but remains visible and the refresh button must be clicked for the view to be updated.
/end problem 2

 
Additional InformationThe current work around is to manually deselect the Pad after hiding it and making sure the sketch is the only selected object in the task view.

OS: Ubuntu 13.10
Platform: 64-bit
Version: 0.14.3342 (Git)
Branch: master
Hash: ca6d37202593752c0eeeb1ce56cb4d8c3baf27c0
Python version: 2.7.5+
Qt version: 4.8.4
Coin version: 4.0.0a
SoQt version: 1.5.0
OCC version: 6.7.0
  
TagsNo tags attached.

Relationships

related to 0001838 closedwmayer Sketcher When In Sketcher Make It Difficult To Mistakenly Delete A Feature 

Activities

wmayer

2014-12-29 15:47

administrator   ~0005464

The strange behaviour is caused by the deletion of the pad. This sets the actual sketch shape back to visible which is not updated at this time abd that's the line you see.

The changes for issue 1838 heals this problem, too.

Issue History

Date Modified Username Field Change
2014-03-18 18:13 quick61 New Issue
2014-12-29 15:47 wmayer Note Added: 0005464
2014-12-29 15:47 wmayer Relationship added related to 0001838
2014-12-29 15:48 wmayer Status new => closed
2014-12-29 15:48 wmayer Assigned To => wmayer
2014-12-29 15:48 wmayer Resolution open => fixed
2014-12-29 15:48 wmayer Fixed in Version => 0.15