View Issue Details

IDProjectCategoryView StatusLast Update
0001446FreeCADBugpublic2014-03-15 13:15
ReporterrolbitAssigned Towmayer 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformWindowsOSWindows serverOS Version 2008 r2
Product Version0.14 
Target VersionFixed in Version0.14 
Summary0001446: STEP export fails under Windows
DescriptionExport from GUI to STEP fails under windows, there is no file generated.
If I look at the python console it uses the following commands:

>>> __objs__=[]
>>> __objs__.append(FreeCAD.getDocument("Unnamed").getObject("Box"))
>>> import ImportGui
>>> ImportGui.export(__objs__,"C:/Users/bitterli/Documents/test.step")
>>> del __objs__

It works if I use manually the following commands:

>>> import Part
>>> __objs__=[]
>>> __objs__.append(FreeCAD.getDocument("Unnamed").getObject("Box"))
>>> Part.export(__objs__,"C:/Users/bitterli/Documents/test.stp")
>>> del __objs__
>>>
Additional InformationOS: Windows 7
Platform: 32-bit
Version: 0.14.2370 (Git)
Branch: master
Hash: a836759ebd91404954a778ff8885e152611576e1
Python version: 2.6.2
Qt version: 4.5.2
Coin version: 3.1.0
SoQt version: 1.4.1
OCC version: 6.5.1
TagsNo tags attached.

Relationships

duplicate of 0001210 closed DLL load failed 

Activities

rolbit

2014-02-26 10:31

reporter  

test.FCStd (Attachment missing)

wmayer

2014-02-26 13:27

administrator   ~0004307

When trying to do the export with the GUI do you get an error message? You can also enter "import ImportGui" into the Python console to see whether the module loads or not.

rolbit

2014-02-26 14:02

reporter   ~0004308

there is an error message when trying to load importGUI.:

 import ImportGui
Traceback (most recent call last):
  File "<input>", line 1, in <module>
ImportError: DLL load failed: The specified module could not be found.

wmayer

2014-02-26 14:53

administrator   ~0004309

OK, this means that the install package lacks of a certain file. We had this in the past but I don't know why this happened again.

wmayer

2014-02-26 15:03

administrator   ~0004310

Here is the corresponding forum link:
http://forum.freecadweb.org/viewtopic.php?f=3&t=4627&p=36273&hilit=importgui#p36273
http://www.freecadweb.org/tracker/view.php?id=1210

wmayer

2014-03-15 13:15

administrator   ~0004451

Fixed with the latest installer versions for 0.14

Issue History

Date Modified Username Field Change
2014-02-26 10:31 rolbit New Issue
2014-02-26 10:31 rolbit File Added: test.FCStd
2014-02-26 13:27 wmayer Note Added: 0004307
2014-02-26 14:02 rolbit Note Added: 0004308
2014-02-26 14:53 wmayer Note Added: 0004309
2014-02-26 15:03 wmayer Note Added: 0004310
2014-02-26 15:03 wmayer Relationship added duplicate of 0001210
2014-03-15 13:15 wmayer Note Added: 0004451
2014-03-15 13:15 wmayer Status new => closed
2014-03-15 13:15 wmayer Assigned To => wmayer
2014-03-15 13:15 wmayer Resolution open => fixed
2014-03-15 13:15 wmayer Fixed in Version => 0.14
2014-03-15 13:15 wmayer Product Version 0.13 => 0.14