View Issue Details

IDProjectCategoryView StatusLast Update
0001424FreeCADBugpublic2014-04-14 22:01
ReporterjmaustpcAssigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Platform64 bitOSKubuntuOS Version12.04
Product Versiontrunk 
Target VersiontrunkFixed in Version0.14 
Summary0001424: emn import failure
Descriptionimport of this emn file attached produces many individual wires not solids

with the following error message

Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/home/user/Downloads/cad/build/Mod/Idf/Idf.py", line 66, in open
    process_emn(doc,filename)
  File "/home/user/Downloads/cad/build/Mod/Idf/Idf.py", line 132, in process_emn
    place_steps(doc,placement,board_thickness)
  File "/home/user/Downloads/cad/build/Mod/Idf/Idf.py", line 330, in place_steps
    model_file=pythonopen(model_tab_filename, "r")
<type 'exceptions.IOError'>: (2, 'No such file or directory', '/home/user/Downloads/cad/build/data/Mod/Idf/lib/footprints_models.csv')

the attached 7zip file includes the emn file and the fcstd file
Additional InformationOS: Ubuntu 12.04.4 LTS
Platform: 64-bit
Version: 0.14.3167 (Git)
Branch: master
Hash: bb98b5afb0890d786da88aaf8dc8bf05872c5d7a
Python version: 2.7.3
Qt version: 4.8.2
Coin version: 3.1.3
SoQt version: 1.5.0
OCC version: 6.5.0
TagsNo tags attached.

Relationships

related to 0001505 closedwmayer Fix multiple bugs in Idf.py 

Activities

jmaustpc

2014-02-19 15:28

manager  

LEDs.7z (Attachment missing)

herman15

2014-02-20 08:30

reporter   ~0004249

Just imported your Board file without the error messages with individual wires.
To get the view as Solids switch the view Style (In my german version "Ansicht->Zeichenstil->Flat Lines","Ansicht->Zeichenstil->Shaded")

The reason of the error message:
Freecad EMN import expect a file "footprints_models.csv" in your Freecad Resource Directory. (in your case: "/home/user/Downloads/cad/build/data/")
see your Python import script Idf.py

jmaustpc

2014-03-04 16:01

manager   ~0004381

I was wrong about the import as wire comment but not the error message.

The import simply has the solids in wireframe display mode, each component on the board in this model is made from several different solids, which surprised me, I expected they would be one solid, hence when I thought I had found all the different wires in the model I was actually finding various sub-solids in wireframe display mode.

Of course the next question is shouldn't these be imported by default in FaltLines display mode?


Here is a link to the beginning of the topic on the forum

http://forum.freecadweb.org/viewtopic.php?f=3&t=5848


regarding the error message at this point in the above linked topic a solution has been proposed
http://forum.freecadweb.org/viewtopic.php?f=3&t=5848#p47740

As far as I can tell the solution proposed look reasonable, but could one of you who understands this matter have a look and pull this, if it is correct, please?

nickoe

2014-04-14 20:18

reporter   ~0004561

This should be marked as resolved, it is fixed in bug 0001505.

Issue History

Date Modified Username Field Change
2014-02-19 15:28 jmaustpc New Issue
2014-02-19 15:28 jmaustpc File Added: LEDs.7z
2014-02-19 15:41 jmaustpc Additional Information Updated View Revisions
2014-02-20 08:30 herman15 Note Added: 0004249
2014-03-04 16:01 jmaustpc Note Added: 0004381
2014-04-14 20:18 nickoe Note Added: 0004561
2014-04-14 22:00 wmayer Relationship added related to 0001505
2014-04-14 22:01 wmayer Status new => closed
2014-04-14 22:01 wmayer Resolution open => fixed
2014-04-14 22:01 wmayer Fixed in Version => 0.14