View Issue Details

IDProjectCategoryView StatusLast Update
0001285FreeCADFeaturepublic2017-03-27 08:28
ReporterickbyAssigned To 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Versiontrunk 
Target VersionFixed in Version0.14 
Summary0001285: Rotation constructor from vector/to vector not exposed in python
DescriptionThe c++ constructor for Base.Rotation with two given vectors is not exposed in python. Therefore it is currently not possible to create a rotation/placement to a given vector without calculating it by hand. This is a serious limitation, especially because the c++ api has these functions already.

Note thet the python rotation class documentation states vector/vector as a valid constructor, even if it does not exist.
TagsNo tags attached.

Activities

ickby

2013-10-23 07:18

developer   ~0003788

Last edited: 2013-10-23 10:12

ok, stupid me... it does of course work. Seems I cant delete this report, could some one do this please?

wmayer

2013-10-23 13:23

administrator   ~0003790

... but the documentation is not up to date.

git show f5e12c7

Issue History

Date Modified Username Field Change
2013-10-23 06:50 ickby New Issue
2013-10-23 07:18 ickby Note Added: 0003788
2013-10-23 10:12 ickby Note Edited: 0003788
2013-10-23 13:23 wmayer Note Added: 0003790
2013-10-23 13:23 wmayer Status new => closed
2013-10-23 13:23 wmayer Resolution open => fixed
2013-10-23 13:23 wmayer Fixed in Version => 0.14
2017-03-27 08:28 Kunda1 Changeset attached => FreeCAD master f5e12c74