View Issue Details

IDProjectCategoryView StatusLast Update
0001263PartDesignFeaturepublic2016-10-15 20:34
ReporterbejantAssigned Tonormandc 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.13 
Target VersionFixed in Version0.14 
Summary0001263: Allow On-The-Fly Constraints for Measure Distance Tool
DescriptionThe Measure Distance tool (tape measure icon) could be more helpful if the user could toggle to constrain distance to the X, Y, and Z axes if needed. Another helpful feature would be if a user could select two parallel faces having for example different locations on the Z-axis) then click the Measure Distance tool and get the distance between faces. This was mentioned in the following forum thread:
http://sourceforge.net/apps/phpbb/free-cad/viewtopic.php?f=3&t=4641&start=0

Additional InformationThis feature is not in my FC version:
OS: Windows XP
Platform: 32-bit
Version: 0.14.2370 (Git)
Branch: master
Hash: a836759ebd91404954a778ff8885e152611576e1
Python version: 2.6.2
Qt version: 4.5.2
Coin version: 3.1.0
SoQt version: 1.4.1
OCC version: 6.5.1
TagsNo tags attached.

Relationships

related to 0000503 assignedwmayer FreeCAD Measurement framework 

Activities

normandc

2016-10-09 08:12

manager   ~0007350

Is this bug still relevant, now that the Part workbench has the Measure toolbar?

bejant

2016-10-09 13:25

reporter   ~0007352

No, I think this ticket should be closed.
New link to the forum topic as forum has since moved from SF:
http://forum.freecadweb.org/viewtopic.php?f=3&t=4641

normandc

2016-10-15 20:34

manager   ~0007374

Requested functionality was implemented differently through the Measure tools in the Part workbench.

Issue History

Date Modified Username Field Change
2013-10-01 23:35 bejant New Issue
2013-10-02 06:31 wmayer Relationship added related to 0000503
2016-10-09 08:12 normandc Note Added: 0007350
2016-10-09 13:25 bejant Note Added: 0007352
2016-10-15 20:34 normandc Note Added: 0007374
2016-10-15 20:34 normandc Status new => closed
2016-10-15 20:34 normandc Assigned To => normandc
2016-10-15 20:34 normandc Resolution open => fixed
2016-10-15 20:34 normandc Fixed in Version => 0.14