View Issue Details

IDProjectCategoryView StatusLast Update
0001252AssemblyBugpublic2015-01-08 06:56
Reporterproject4Assigned Tojmaustpc 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Versiontrunk 
Target VersionFixed in Version0.14 
Summary0001252: Creating assembly on a file created from PartsDesigner
DescriptionStart in PartsDesigner workbench, create a new document.
Now move to assembly workbench.

Trying to add existing component doesn't work.
Pressing on "Add new component" toolbar adds "Product_0" to the model tree.
Selecting the "Product_0" and pressing "add existing component" opens the dialog to select STP file, selecting one and pressing Open creates STP_Part_1 entry on the same level as the Product_0, while I would expect it to be placed in the Product_0 as its parent entry.

No models are shown, only the initial sketch axis from the PartsDesigner.

Something gets wrong with the model tree in that case.

I've tried to add a new document from the assembly workbench, while this one is open, than the second file behaves the same problematic way.
Additional InformationConsole have some traceback printouts:
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/home/alex/Workspace/FreeCad/assembly/Mod/Assembly/AssemblyLib.py", line 70, in importAssembly
    DestItem.Items = DestItem.Items + [po]
<type 'exceptions.AttributeError'>: 'NoneType' object has no attribute 'Items'
Stack Trace: Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/home/alex/Workspace/FreeCad/assembly/Mod/Assembly/AssemblyLib.py", line 70, in importAssembly
    DestItem.Items = DestItem.Items + [po]

Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/home/alex/Workspace/FreeCad/assembly/Mod/Assembly/AssemblyLib.py", line 70, in importAssembly
    DestItem.Items = DestItem.Items + [po]
<type 'exceptions.AttributeError'>: 'NoneType' object has no attribute 'Items'
Stack Trace: Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/home/alex/Workspace/FreeCad/assembly/Mod/Assembly/AssemblyLib.py", line 70, in importAssembly
    DestItem.Items = DestItem.Items + [po]

Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/home/alex/Workspace/FreeCad/assembly/Mod/Assembly/AssemblyLib.py", line 70, in importAssembly
    DestItem.Items = DestItem.Items + [po]
<type 'exceptions.AttributeError'>: 'NoneType' object has no attribute 'Items'
Stack Trace: Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/home/alex/Workspace/FreeCad/assembly/Mod/Assembly/AssemblyLib.py", line 70, in importAssembly
    DestItem.Items = DestItem.Items + [po]


I'm on latest assembly branch.

OS: Ubuntu 13.04
Platform: 64-bit
Version: 0.14.2654 (Git)
Branch: jriegel/dev-assembly
Hash: 3d4dd4f64f24255dbaec25767cff7b74bb98fc6d
Python version: 2.7.4
Qt version: 4.8.4
Coin version: 3.1.3
SoQt version: 1.5.0
OCC version: 6.5.0

TagsNo tags attached.

Activities

ickby

2013-09-24 17:12

developer   ~0003648

I fixed this in the assembly branch of git@github.com:ickby/FreeCAD_constraint.git

project4

2013-09-24 18:35

reporter   ~0003653

I'm currently on jriegel/dev-assembly, should I use your branch instead or the one I use should aggregate all your changes as well after a while?

ickby

2013-09-25 03:04

developer   ~0003656

My branch will be merged from time to time into jriegel/dev-assembly, however, I can't say when this happens as this is jriegels branch and he does the merging. You can use my branch, as jriegel is not activly developing at the moment and therefore you will miss nothing. That can of course change any time :)

project4

2013-09-25 03:54

reporter   ~0003657

OK, will move to yours.
Thanks.

project4

2013-09-25 07:26

reporter   ~0003658

I'm not sure whether I cloned the right repository...

Trying git clone git@github.com:ickby/FreeCAD_constraint.git assembly_ickby
I get:
Permission denied (publickey).
fatal: Could not read from remote repository.
Please make sure you have the correct access rights
and the repository exists.

I've found another repository with your branch name:
git clone https://github.com/ickby/FreeCAD_constraint.git assembly_ickby

But after compiling I see the old assembly module with only 1 button in the toolbar...

Can you please guide me how to clone your branch?

Thanks.

ickby

2013-09-25 10:13

developer   ~0003661

Last edited: 2013-09-25 10:23

you need the "assembly" branch, clone the repository and checkout the branch after that.

do

git clone https://github.com/ickby/FreeCAD_constraint.git assembly_ickby
cd assembly_ickby
git checkout assembly

it's basicaly the same if you switch
git@github.com:ickby/FreeCAD_constraint.git
for
https://github.com/ickby/FreeCAD_constraint.git

To see which branches are available after cloning type "git branch". You can also addd the repository as remote to make later updates easyer:

git remote add ickbys_repo https://github.com/ickby/FreeCAD_constraint.git

ans later for updating:

git pull ickbys_repo assembly

project4

2013-09-25 10:40

reporter   ~0003662

Thanks, trying now.

Actually before checking out the assembly branch in your repository command "git branch" shows only the master branch.

Should probably use "git branch -a" to see all.

project4

2013-09-25 13:33

reporter   ~0003665

Confirm that the problem was fixed on ickby's branch.

Issue History

Date Modified Username Field Change
2013-09-24 16:09 project4 New Issue
2013-09-24 17:12 ickby Note Added: 0003648
2013-09-24 18:35 project4 Note Added: 0003653
2013-09-25 03:04 ickby Note Added: 0003656
2013-09-25 03:54 project4 Note Added: 0003657
2013-09-25 07:26 project4 Note Added: 0003658
2013-09-25 10:13 ickby Note Added: 0003661
2013-09-25 10:18 ickby Note Edited: 0003661
2013-09-25 10:23 ickby Note Edited: 0003661
2013-09-25 10:40 project4 Note Added: 0003662
2013-09-25 13:33 project4 Note Added: 0003665
2015-01-08 06:56 jmaustpc Status new => closed
2015-01-08 06:56 jmaustpc Assigned To => jmaustpc
2015-01-08 06:56 jmaustpc Resolution open => fixed
2015-01-08 06:56 jmaustpc Fixed in Version => 0.14