View Issue Details

IDProjectCategoryView StatusLast Update
0001172FreeCADBugpublic2014-03-10 23:26
ReporterrocketshipAssigned Towmayer 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.13 
Target VersionFixed in Version0.14 
Summary0001172: Installation should set Python path
DescriptionInstaller should either set correct Python path or place FreeCAD libraries within the existing Python path. When using FreeCAD libraries in Python outside of FreeCAD, they should automatically be found with "import FreeCAD".

One of the sample scripts suggests manually setting the path to the FreeCAD libs at the beginning of the script, but this breaks cross-platform because the path is different.

This should be invisible to the end user. Thanks!
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2013-07-10 12:07 rocketship New Issue
2014-03-10 23:26 wmayer Changeset attached => FreeCAD Master master 7176c0d9
2014-03-10 23:26 wmayer Status new => closed
2014-03-10 23:26 wmayer Assigned To => wmayer
2014-03-10 23:26 wmayer Resolution open => fixed
2014-03-10 23:26 wmayer Fixed in Version => 0.14