View Issue Details

IDProjectCategoryView StatusLast Update
0001106FreeCADBugpublic2013-05-13 12:36
ReporterrswarbrickAssigned To 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product Versiontrunk 
Target VersionFixed in Version0.14 
Summary0001106: Segfault when selecting a duplicate pad
DescriptionWhen selecting the data panel and "Bracket Cut Pad 002" in the attached file, FreeCAD segfaults.

I created a pad of a (very) simple sketch - a rectangle, in fact. Then used Edit/Duplicate Selection to create a couple of duplicates. The plan was then to offset them slightly unusually and then cut the lower bracket object by them.

I haven't tried to debug this, but one possibility for the segfault is the naming scheme: I named the first object "Bracket Cut Pad 001". Maybe the code is looking for "Bracket Cut Pad" somewhere?
TagsNo tags attached.

Relationships

related to 0001111 closed PartDesign Deleting sketch after padding was done crashes the program 

Activities

2013-04-22 11:26

 

full-heatsink.fcstd (Attachment missing)

wandererfan

2013-04-23 10:35

developer   ~0003102

Last edited: 2013-04-29 21:34

further info: in the project tree, a double click on "Bracket Cut Pad 002" or "Bracket Cut Pad 003" fails. a double click on Bracket Cut Pad 001" brings up the Pad Parameters dialog in the Task panel.

Modfiying "Bracket Cut Pad 002" pad length in Data tab of Property panel yields "No Sketch Linked" and a changed (red circle with lc "i"?) icon in the project tree. Pad length change is not reflected in model, but is reflected in Property.

Moving "Bracket Cut Pad 002" by changing position in Data tab works, but also produces "No Sketch Linked".

Should "Duplicate Selection" preserve link to underlying sketch? or produce a new duplicate sketch properly linked to "Bracket Cut Pad 002"?

>>> EDIT: "Duplicate Selection" is a "simple copy" (non-parametric) so it isn't supposed to keep a link to the original. But if it is non-parametric, why are there parameters in Data tab? Should be just a dumb shape?

OS: Ubuntu 12.04.2 LTS
Platform: 64-bit
Version: 0.13.1830 (Git)
Branch: releases/FreeCAD-0-13
Hash: ec7636d7aaf2612e9b43cff5d6a424037d53e505
Python version: 2.7.3
Qt version: 4.8.1
Coin version: 3.1.3
SoQt version: 1.5.0
OCC version: 6.5.0

wandererfan

2013-04-30 19:49

developer   ~0003128

This does not happen in Version: 0.13.2084 (Git). Also there is now a MessageBox for "input error no sketch linked". Problem solved?

wmayer

2013-05-13 12:35

administrator   ~0003150

The report actually describes the same bug as in #0001111. The problem was that the Pad feature crashed if no sketch was linked to it.

The old version of "Duplicate selection" (this has changed now) created copies with no links and thus the above happens.

So, this bug is fixed now.

Issue History

Date Modified Username Field Change
2013-04-22 11:26 rswarbrick New Issue
2013-04-22 11:26 rswarbrick File Added: full-heatsink.fcstd
2013-04-23 10:35 wandererfan Note Added: 0003102
2013-04-23 10:37 wandererfan Note Edited: 0003102
2013-04-29 21:31 wandererfan Note Edited: 0003102
2013-04-29 21:34 wandererfan Note Edited: 0003102
2013-04-30 19:49 wandererfan Note Added: 0003128
2013-05-13 12:35 wmayer Note Added: 0003150
2013-05-13 12:35 wmayer Relationship added related to 0001111
2013-05-13 12:36 wmayer Status new => closed
2013-05-13 12:36 wmayer Resolution open => fixed
2013-05-13 12:36 wmayer Fixed in Version => 0.14