View Issue Details

IDProjectCategoryView StatusLast Update
0001098FreeCADFeaturepublic2015-10-06 11:49
ReporterfsamirAssigned Toabdullah 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version0.13 
Target VersionFixed in Version0.16 
Summary0001098: Add ability to use variables and forumulas
DescriptionHi there,

it would be nice (at least for people coming from parametric software like OpenSCAD) to be able to use constants, variables and formulas for constraints and dimensions.

Something like ${external_width / 2} where $external_width would be defined in a parameters screen.
TagsNo tags attached.

Relationships

duplicate of 0000800 closedlogari81 Sketcher Formula/Equation Based Constraints 

Activities

normandc

2013-04-17 20:44

manager   ~0003074

This is a duplicate of https://sourceforge.net/apps/mantisbt/free-cad/view.php?id=800

abdullah

2015-10-06 11:49

manager   ~0006479

Expressions have been implemented:
http://forum.freecadweb.org/viewtopic.php?f=10&t=8802&start=190 [^]

Issue History

Date Modified Username Field Change
2013-04-16 04:39 fsamir New Issue
2013-04-17 20:44 normandc Note Added: 0003074
2014-08-19 02:09 normandc Relationship added duplicate of 0000800
2015-10-06 11:49 abdullah Note Added: 0006479
2015-10-06 11:49 abdullah Status new => closed
2015-10-06 11:49 abdullah Assigned To => abdullah
2015-10-06 11:49 abdullah Resolution open => fixed
2015-10-06 11:49 abdullah Fixed in Version => 0.16