View Issue Details

IDProjectCategoryView StatusLast Update
0001087FreeCADBugpublic2013-04-27 18:11
ReporterbrnrdAssigned Towmayer 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.13 
Target VersionFixed in Version0.14 
Summary0001087: Inventor Navigation continues with released Mouse Button
DescriptionOn Windows XP

How I reproduce this:
- Start FreeCAD
- Menu|File|New
- On Document space, right click|Navigation Styles|Inventor Navigation
- Select Part Design workbench
- In Tasks, select "Create sketch"
- Confirm all defaults - X-Y plane etc in dialog and click OK
- Select the rectangle tool and draw a rectangle

It is not possible to do this because of the Inventor Navigation which rotates the patch.

- Press escape twice

The sketch disappears from view

- On Document space, right click|Navigation Styles|CAD Navigation
- Draw the recangle
- Close the editing
- Select the rectangle and pad it
- Press ok
- On Document space, right click|Navigation Styles|Inventor Navigation
- Click on the surface of the box and drag it with the left mouse button to rotate
- Release the left mouse button
- Move the mouse

Expected behavior: The box should stay in place

Actual behavior: The box (selected whole) rotates following the mouse movement as if the left mouse button is clicked which it is not.

The action can only be stopped if the left mouse button is clicked while it is outside the box shape.

This behavior of sticking rotation was very reproducible in multiple sessions, and it also happened even with CAD navigation setting, but I cannot reproduce this now. I have seen it only when using the part design workbench, but this may not mean much because otherwise I was scripting shapes not using workbenches.
TagsNo tags attached.

Activities

wmayer

2013-04-15 09:12

administrator   ~0003066

The first part of your error report seems to be irrelevant. It is sufficient to start directly with CAD style and create the sketch. The important point is to leave the sketch edit mode with ESC instead of clicking on Close. If you now create the pad and switch back to Inventor style you have the described behaviour.

wmayer

2013-04-27 18:11

administrator   ~0003118

git show 859cf78

Issue History

Date Modified Username Field Change
2013-04-07 17:57 brnrd New Issue
2013-04-15 09:12 wmayer Note Added: 0003066
2013-04-15 09:13 wmayer Assigned To => wmayer
2013-04-15 09:13 wmayer Severity major => minor
2013-04-15 09:13 wmayer Status new => confirmed
2013-04-27 18:11 wmayer Note Added: 0003118
2013-04-27 18:11 wmayer Status confirmed => closed
2013-04-27 18:11 wmayer Resolution open => fixed
2013-04-27 18:11 wmayer Fixed in Version => 0.14