View Issue Details

IDProjectCategoryView StatusLast Update
0001079FreeCADBugpublic2013-04-03 12:44
ReporterbrnrdAssigned Towmayer 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version0.13 
Target VersionFixed in Version0.14 
Summary0001079: Task Deadlock: Part Workbench disabled when closing Combo View with open Task
DescriptionHow I reproduce this:

- Start FreeCAD
- Menu|File|New
- Switch to Part Workbench
- Click on icon "Advanced utitility to create shapes"
- In this panel, click the window close icon "X" (not the "Close" button) in the Combo View Panel

Expected behavior:
Perhaps FreeCAD should prompt me for aborting the edit operation but I am not sure about this because the issue is somewhat deeper.

Actual behavior:

The Combo View Panel disappears and the Part Workbench is disabled. No way to figure out why, except of course:
Menu|View|Views|Combo View|Tasks|Close

Menu|Edit|Toggle Edit Mode| does not fix it.

This is a fundamental dilemma with the FreeCAD GUI: FreeCAD can put the user into a deadlocking task mode that is why I call this "Task Deadlock"

Perhaps modal dialogs are the solution for this.

Another way of looking at this would be an enhanced toolbar that knows why it is disabled. The user would then be able to select from a menu of options when clicking on the disabled toolbar. Options would be to show the closed Combo View Panel with the task open, and an option to abort the current task.
TagsNo tags attached.

Activities

wmayer

2013-04-03 12:05

administrator   ~0003032

I agree that this is a dilemma. However, it's a general issue and happens with all other task panels, too. It's not limited to the "Advanced utility to create shapes".

> Perhaps modal dialogs are the solution for this.
No, definitely not! Modal dialogs should be avoided whenever possible, because:
1. this forces the user to do exactly one thing when there is actually no need for it. Modal dialogs should only be used if it's important that the user finishes (or aborts) the started operation.
2. Opening a modal dialog always covers a part of the 3d view and thus there is always the situation where exactly the part is hidden which is interesting to the user. So, he has to manually drag it somewhere else.
3. Modal dialogs cause a redraw of the 3d view which can be an expensive operation.
4. And the most important point is that almost all of the commands using a task panel require the user to interact with the 3d view. Using a modal dialog would disallow that and thus would be useless.

So, the solution can only be to disallow that the dock widget can be hidden, at least while a task panel is opened.

wmayer

2013-04-03 12:44

administrator   ~0003034

git show bc74543

Issue History

Date Modified Username Field Change
2013-04-02 16:33 brnrd New Issue
2013-04-03 12:05 wmayer Note Added: 0003032
2013-04-03 12:43 wmayer Status new => assigned
2013-04-03 12:43 wmayer Assigned To => wmayer
2013-04-03 12:44 wmayer Note Added: 0003034
2013-04-03 12:44 wmayer Status assigned => closed
2013-04-03 12:44 wmayer Resolution open => fixed
2013-04-03 12:44 wmayer Fixed in Version => 0.14