View Issue Details

IDProjectCategoryView StatusLast Update
0001077FreeCADBugpublic2013-04-03 11:23
ReporterbrnrdAssigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version0.13 
Target VersionFixed in Version0.14 
Summary0001077: Placement Panel not removed after Entity Deletion
DescriptionWhat I do:
- Create a Box solid, getting Box001
- Click on it in the Labels and Attributes panel
- Click on the button with the ellipses to get the Placement panel
- In the Labels and Attributes panel, click on Box001 and Delete

Expected behavior: The Placement panel should be removed and I should be able to create a new box.

Actual Behavior: The Part tool palette is disabled because the Placement panel is still active.

Note: This is very confusing for beginners because there is no way to figure out why the workbench is disabled.
TagsNo tags attached.

Activities

brnrd

2013-04-01 18:04

reporter   ~0003022

Actually, this problem would not exist if the Placement panel was a modal dialog where the user would not be able to delete the entity before closing the dialog. So the problem is that the Placement panel is not a modal dialog.

brnrd

2013-04-01 18:07

reporter   ~0003023

Sorry, I am wrong - this can't be a dialog if other actions should be enabled while editing placement.

wmayer

2013-04-03 11:22

administrator   ~0003028

The behaviour has changed that the placement panel doesn't cause to deactivate all the commands. So, you can still create new objects if you want while the panel is open.

But note, the panel still won't be closed when deleting an object from the document. This is intended!

wmayer

2013-04-03 11:23

administrator   ~0003029

git show 0d62206

Issue History

Date Modified Username Field Change
2013-04-01 17:57 brnrd New Issue
2013-04-01 18:04 brnrd Note Added: 0003022
2013-04-01 18:07 brnrd Note Added: 0003023
2013-04-03 11:22 wmayer Note Added: 0003028
2013-04-03 11:23 wmayer Note Added: 0003029
2013-04-03 11:23 wmayer Status new => closed
2013-04-03 11:23 wmayer Resolution open => fixed
2013-04-03 11:23 wmayer Fixed in Version => 0.14