View Issue Details

IDProjectCategoryView StatusLast Update
0001076FreeCADFeaturepublic2013-07-14 12:20
ReporterbrnrdAssigned Towmayer 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.13 
Target VersionFixed in Version0.14 
Summary0001076: Placement Position Entry can be improved
DescriptionWhen we add a new solid to the drawing, then FreeCAD places it at the origin.

As one of the most frequent operation, we will want to change its position and orientation.

What I do:
- Create a Box Solid
- In the Labels and Attributes view, click on the node e.g. Box001
- Click on the label "Height" which highlights/selects the value
- start typing e.g. 55

Expected behavior: FreeCAD should accept the value, overwriting the existing value of 10.00

Actual behavior: FreeCAD executes the first number 5 as standard bottom view command

Notes:

I need this kind of entry as default behavior (value highlighted and ready for editing)
because I don't want to spend any effort to use the mouse to drag over all the existing digits
just to overtype the existing digits.
TagsNo tags attached.

Activities

wmayer

2013-04-03 11:37

administrator   ~0003031

On my system it behaves like this:
When I create and select the box as described and select e.g. the item "Height" in the property editor and press 5 it indeed invokes the standard view command.
This happens because the spin box doesn't have the focus.

However, when I press on the item right to the item "Height" then the spin box gets the focus and pressing 5 has the expected behaviour. And therefore I don't have to select anything because the numbers in the spin box are already selected.

brnrd

2013-04-03 12:26

reporter   ~0003033

Last edited: 2013-04-03 12:29

I may have an old version: 0.13 rev 1828. wmayer, what is your operating system?
I have Windows XP. With the following sequence, I need 3 mouse clicks to get the number into the field, on the first 2 mouse clicks the spin box gets it:

- Click on Label "Height". I mean the label left of the input field. I do this to get the whole "10.00" selected which I want to overtype with 5 so I get 5.00 with one keystroke.
- type a number e.g. 5 -> spin box gets the number
- after this, click between 1 and the first 0
- type 0 -> spin box gets the number again
- after this, click again between 1 and the first 0 -> Only now the field gets focus first time but the highlight is gone
- type 5 -> number 150.00mm is accepted

But I did not want 150. I wanted 5.

On my system, I can see the number field highlighted in blue, but the cursor is not blinking on it. Only after clicking again, I can see the cursor, but the highlight is gone. This is very irritating. I don't see this type of behavior in any other application on this computer. There is an invisible difference between 2 states: 1) highlighted with no focus, 2) highlighted with focus

Even if I double-click on the input field to get 10.0 highlighted and editable, the field still does not get the focus.

wmayer

2013-04-03 12:52

administrator   ~0003035

> what is your operating system?
Currently I'm working on Ubuntu 10.04 with Qt 4.6.2.

> That's a weird behaviour. I'll have a look when I'm next time on Windows 7 and/or XP.

wmayer

2013-07-14 12:20

administrator   ~0003406

git show 56b9694

Issue History

Date Modified Username Field Change
2013-04-01 17:41 brnrd New Issue
2013-04-03 11:37 wmayer Note Added: 0003031
2013-04-03 12:26 brnrd Note Added: 0003033
2013-04-03 12:29 brnrd Note Edited: 0003033
2013-04-03 12:52 wmayer Note Added: 0003035
2013-07-14 12:18 wmayer Status new => assigned
2013-07-14 12:18 wmayer Assigned To => wmayer
2013-07-14 12:20 wmayer Note Added: 0003406
2013-07-14 12:20 wmayer Status assigned => closed
2013-07-14 12:20 wmayer Resolution open => fixed
2013-07-14 12:20 wmayer Fixed in Version => 0.14