View Issue Details

IDProjectCategoryView StatusLast Update
0001075FreeCADFeaturepublic2013-04-07 19:45
ReporterbrnrdAssigned Toyorik 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.13 
Target VersionFixed in Version0.14 
Summary0001075: DWire Command Number Entry Improvement
DescriptionThe multi-point Draft Wire (DWire) command, in numeric entry mode,
appears to require the visiting of all three fields before the [Enter] key completes a single point.

One could complete the entry faster if entry in only a single field would be required to progress to the next point.

This is most obvious in case where one works in the x-y plane where z is always 0.

Of course duplicate points on top of each other should be prevented.

I stumbled on this while working through the Basic_modeling_tutorial page.

I noticed a lack of feedback in the tutorial because the points that one enters are outside the view.
TagsNo tags attached.

Activities

yorik

2013-04-01 12:11

administrator   ~0003021

Very good idea! The enter key should only hop through coordinates that are not greyed out. I'll implement that when I have a little time.

yorik

2013-04-07 19:45

administrator   ~0003051

Added in e167c9e

Now pressing x, y or z while drawing immediately puts the UI in constrained mode, allowing for pretty fast input like:

x 2 <enter> y 4 <enter> x -2 <enter>

Issue History

Date Modified Username Field Change
2013-04-01 05:04 brnrd New Issue
2013-04-01 12:10 yorik Status new => assigned
2013-04-01 12:10 yorik Assigned To => yorik
2013-04-01 12:11 yorik Note Added: 0003021
2013-04-07 19:45 yorik Note Added: 0003051
2013-04-07 19:45 yorik Status assigned => closed
2013-04-07 19:45 yorik Resolution open => fixed
2013-04-07 19:45 yorik Fixed in Version => 0.14