View Issue Details

IDProjectCategoryView StatusLast Update
0001068FreeCADBugpublic2013-04-08 18:02
ReporterastenbergAssigned Toyorik 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Versiontrunk 
Target VersionFixed in Version0.14 
Summary0001068: DXF export of "large" Polyline Curves
DescriptionPleases see screenshot. Upper window is how CamBam (CNC router path generator) interprets the exported DXF from the FreeCAD object in the lower image.

The "DraftGeomUtils.isClockwise" fix got the curve in the right direction, but it almost seems like what is exported is the "missing" part of the ARC in the object. Do you need a check for arcs spanning more than Pi in the importDXF.getWire function? I will try to upload my FCStd file as well.

Thanks for making FreeCAD happen, this is a really impressive tool.
Additional InformationTested on newest Ubuntu daily build. I am exporting DXF from simple object and loading into CamBam v0.9 CNC routing path generator for Windows.
TagsNo tags attached.

Activities

2013-03-25 17:41

 

dxf_export.jpg (Attachment missing)

2013-03-25 17:44

 

test.FCStd (Attachment missing)

yorik

2013-03-26 00:29

administrator   ~0003006

Hm one more dxf arc problem... I'll look into it!

2013-03-26 17:30

 

dxf_export_2.jpg (Attachment missing)

astenberg

2013-03-26 17:38

reporter   ~0003010

Great. I uploaded dxf_export_2.jpg showing another part and the resulting import into my DXF "viewer".

I'm not sure it was obvious in the previous jpg. But before the "isClockWise" fix the arcs at the bottom of the part would be the "other" way. I cannot help think that angle calculation might have been right to start with, only just the wrong part of the circle was exported.. or?

yorik

2013-04-08 18:02

administrator   ~0003054

Submitted a fix in commit 7556071

As far as I could test all works fine now. The problem was that arcs > 180 degrees were treated as < 180 degrees. I added a small function to correct that.

I'm closing this issue now, please reopen if you still find wrong cases.

Issue History

Date Modified Username Field Change
2013-03-25 17:41 astenberg New Issue
2013-03-25 17:41 astenberg File Added: dxf_export.jpg
2013-03-25 17:44 astenberg File Added: test.FCStd
2013-03-26 00:29 yorik Status new => assigned
2013-03-26 00:29 yorik Assigned To => yorik
2013-03-26 00:29 yorik Note Added: 0003006
2013-03-26 17:30 astenberg File Added: dxf_export_2.jpg
2013-03-26 17:38 astenberg Note Added: 0003010
2013-04-08 18:02 yorik Note Added: 0003054
2013-04-08 18:02 yorik Status assigned => closed
2013-04-08 18:02 yorik Resolution open => fixed
2013-04-08 18:02 yorik Fixed in Version => 0.14