View Issue Details

IDProjectCategoryView StatusLast Update
0001064FreeCADBugpublic2013-03-30 12:48
Reportereirc2theredAssigned Towmayer 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.14 
Summary0001064: Crash occurs in version 0.13 when trying to use alignment tool
Descriptionusing two step files with the alignment tool causes the program to crash. FreeCAD exited with code 0 in QT creator
TagsNo tags attached.

Activities

2013-03-24 20:11

 

alignmentBackTrace.txt (Attachment missing)

tanderson69

2013-03-24 20:12

developer   ~0003004

I added the backtrace. This is not related to step files. this can be reproduced with a new document and 2 blocks.

wmayer

2013-03-30 12:48

administrator   ~0003016

Last edited: 2013-03-30 12:52

git show 7c3e6fa

This error report is misleading because it claims it happens in v0.13 which is definitely wrong. The bug has been introduced with the merge of the dev-assembly branch that was done after v0.13 was out.

Issue History

Date Modified Username Field Change
2013-03-24 19:38 eirc2thered New Issue
2013-03-24 20:11 tanderson69 File Added: alignmentBackTrace.txt
2013-03-24 20:12 tanderson69 Note Added: 0003004
2013-03-30 12:45 wmayer Status new => assigned
2013-03-30 12:45 wmayer Assigned To => wmayer
2013-03-30 12:48 wmayer Note Added: 0003016
2013-03-30 12:48 wmayer Status assigned => closed
2013-03-30 12:48 wmayer Resolution open => fixed
2013-03-30 12:48 wmayer Fixed in Version => 0.14
2013-03-30 12:52 wmayer Note Edited: 0003016