View Issue Details

IDProjectCategoryView StatusLast Update
0001059FreeCADBugpublic2013-03-23 14:46
ReportercrashfridhAssigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.14 
Summary0001059: Cannot add object to DocumentObjectGroupPython
DescriptionIt is not possible to (graphically) add objects to an instance of App::DocumentObjectGroupPython like you can with App::DocumentObjectGroup since it doesn't seem to have the required methods (addObject).
Additional InformationI was happy to see this object type as it is VERY useful for my use case.
TagsNo tags attached.

Activities

crashfridh

2013-03-22 11:20

reporter   ~0002995

Seems to be partially fixed in ce0e6e5cef1022e9bb9e3e3275d17528b376d33f
The object now has the DocumentGroup methods to e.g. add an object. However, graphically it doesn't show yet whether the group has objects or not. It is also not yet possible to add/remove objects graphically.

wmayer

2013-03-23 13:44

administrator   ~0002997

The above commit was needed to simplify things and this also added the methods to add properties to DocumentObjectGroupPython.
The actual fix for this is already in progress...

wmayer

2013-03-23 14:46

administrator   ~0002998

git show b7658c0

Issue History

Date Modified Username Field Change
2013-03-18 03:37 crashfridh New Issue
2013-03-22 11:20 crashfridh Note Added: 0002995
2013-03-23 13:44 wmayer Note Added: 0002997
2013-03-23 14:46 wmayer Note Added: 0002998
2013-03-23 14:46 wmayer Status new => closed
2013-03-23 14:46 wmayer Resolution open => fixed
2013-03-23 14:46 wmayer Fixed in Version => 0.14